Subversive install for Eclipse has finally improved!

About a year ago the Subversive plugin moved into the Eclipse foundation and became the "official" SVN provider plugin for the platform. Unfortunately due to a licensing issue popular SVN connectors such as JavaHL and SVNKit cannot be shipped with the Eclipse IDE, so a fully-functional SVN Team Provider can't currently (and may never?) ship with Eclipse. The steps required previous to install and get Subversive working were pretty tedious in the past, so I'm happy to report that recently this experience has been greatly improved! There are now only two very straightforward steps to get Subversive running:

Launch the Eclipse plugin installer dialog and select "Subversive SVN Team Provider."

Install_subversive_svn_provider

After installation, restart the workbench.  Then open the "SVN Repository Explorer" perspective.  The following dialog will be displayed automatically:

Install_svn_connectors

Choose a SVN connector (I typically use the latest SVNKit), click Finish, restart the workbench one more time and you're ready to go.  Hopefully the licensing issues will be resolved eventually so that Eclipse can ship with the Subversive SVN Team Provider by default but at least in the mean time the installation's been made pretty painless.